#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\/(?<lang>[a-z]{2})-(?<country>[A-Z]{2})\/"
Local $sString = "http://example.com/ja-JP/blog/12345"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)