$re = '/\/(?<lang>[a-z]{2})-(?<country>[A-Z]{2})\//m';
$str = 'http://example.com/ja-JP/blog/12345';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;