using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/(?<lang>[a-z]{2})-(?<country>[A-Z]{2})\/";
string substitution = @"";
string input = @"http://example.com/ja-JP/blog/12345";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}