use strict;
my $str = 'http://example.com/ja-JP/blog/12345';
my $regex = qr/\/(?<lang>[a-z]{2})-(?<country>[A-Z]{2})\//mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";