// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/(?<lang>[a-z]{2})-(?<country>[A-Z]{2})\/").unwrap();
let string = "http://example.com/ja-JP/blog/12345";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}