import Foundation
let pattern = #"\/(?<lang>[a-z]{2})-(?<country>[A-Z]{2})\/"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"http://example.com/ja-JP/blog/12345"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)