using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http:\/\/aws-artworkapproval.*?)""";
string input = @"http://aws-artworkapproval"" xdt:Transform=""SetAttributes"" xdt:Locator=""Match(key)""
http://aws-artworkapproval-dev"" xdt:Transform=""SetAttributes"" xdt:Locator=""Match(key)""
http://aws-artworkapproval-test"" xdt:Transform=""SetAttributes"" xdt:Locator=""Match(key)""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}