$re = '/(http:\/\/aws-artworkapproval.*?)"/m';
$str = 'http://aws-artworkapproval" xdt:Transform="SetAttributes" xdt:Locator="Match(key)"
http://aws-artworkapproval-dev" xdt:Transform="SetAttributes" xdt:Locator="Match(key)"
http://aws-artworkapproval-test" xdt:Transform="SetAttributes" xdt:Locator="Match(key)"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);