import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http:\\/\\/aws-artworkapproval.*?)\"";
final String string = "http://aws-artworkapproval\" xdt:Transform=\"SetAttributes\" xdt:Locator=\"Match(key)\"\n"
+ "http://aws-artworkapproval-dev\" xdt:Transform=\"SetAttributes\" xdt:Locator=\"Match(key)\"\n"
+ "http://aws-artworkapproval-test\" xdt:Transform=\"SetAttributes\" xdt:Locator=\"Match(key)\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}