package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(http:\/\/aws-artworkapproval.*?)"`)
var str = `http://aws-artworkapproval" xdt:Transform="SetAttributes" xdt:Locator="Match(key)"
http://aws-artworkapproval-dev" xdt:Transform="SetAttributes" xdt:Locator="Match(key)"
http://aws-artworkapproval-test" xdt:Transform="SetAttributes" xdt:Locator="Match(key)"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}