re = /(http:\/\/aws-artworkapproval.*?)"/m
str = 'http://aws-artworkapproval" xdt:Transform="SetAttributes" xdt:Locator="Match(key)"
http://aws-artworkapproval-dev" xdt:Transform="SetAttributes" xdt:Locator="Match(key)"
http://aws-artworkapproval-test" xdt:Transform="SetAttributes" xdt:Locator="Match(key)"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end