// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(http:\/\/aws-artworkapproval.*?)""#).unwrap();
let string = "http://aws-artworkapproval\" xdt:Transform=\"SetAttributes\" xdt:Locator=\"Match(key)\"
http://aws-artworkapproval-dev\" xdt:Transform=\"SetAttributes\" xdt:Locator=\"Match(key)\"
http://aws-artworkapproval-test\" xdt:Transform=\"SetAttributes\" xdt:Locator=\"Match(key)\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}