const regex = /(http:\/\/aws-artworkapproval.*?)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http:\\\/\\\/aws-artworkapproval.*?)"', 'gm')
const str = `http://aws-artworkapproval" xdt:Transform="SetAttributes" xdt:Locator="Match(key)"
http://aws-artworkapproval-dev" xdt:Transform="SetAttributes" xdt:Locator="Match(key)"
http://aws-artworkapproval-test" xdt:Transform="SetAttributes" xdt:Locator="Match(key)"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}