# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*?(?!.*\\/)(.*)\?.*/app\/data\/$1.json/g;t' <<< "/api/bpm/fetch-action-progress-bar?bpm=123"