#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".*?(?!.*\/)(.*)\?.*"
Local $sString = "/api/bpm/fetch-action-progress-bar?bpm=123"
Local $sSubst = "app/data/$1.json"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)