use strict;
my $str = '/api/bpm/fetch-action-progress-bar?bpm=123';
my $regex = qr/.*?(?!.*\/)(.*)\?.*/p;
my $subst = 'app/data/$1.json';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";