import Foundation
let pattern = #".*?(?!.*\/)(.*)\?.*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"/api/bpm/fetch-action-progress-bar?bpm=123"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"app/data/$1.json"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)