const regex = /.*?(?!.*\/)(.*)\?.*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?(?!.*\\\/)(.*)\\?.*', 'g')
const str = `/api/bpm/fetch-action-progress-bar?bpm=123`;
const subst = `app/data/$1.json`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);