$re = '/.*?(?!.*\/)(.*)\?.*/';
$str = '/api/bpm/fetch-action-progress-bar?bpm=123';
$subst = "app/data/$1.json";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;