using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?(?!.*\/)(.*)\?.*";
string substitution = @"app/data/$1.json";
string input = @"/api/bpm/fetch-action-progress-bar?bpm=123";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}