# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=[\hA-Z])[A-Z]$|[A-Z](?=[\hA-Z])/$0./gm;t' <<< "Patrick TJ Stephens
TJ Stephens
TJ Stephens QC
Marissa C J Gilbert
Marissa C Gilbert
C Marissa Gilbert
Marissa Gilbert C"