using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[\hA-Z])[A-Z]$|[A-Z](?=[\hA-Z])";
string substitution = @"$0.";
string input = @"Patrick TJ Stephens
TJ Stephens
TJ Stephens QC
Marissa C J Gilbert
Marissa C Gilbert
C Marissa Gilbert
Marissa Gilbert C";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}