#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=[\hA-Z])[A-Z]$|[A-Z](?=[\hA-Z])"
Local $sString = "Patrick TJ Stephens" & @CRLF & _
"TJ Stephens" & @CRLF & _
"TJ Stephens QC" & @CRLF & _
"Marissa C J Gilbert" & @CRLF & _
"Marissa C Gilbert" & @CRLF & _
"C Marissa Gilbert" & @CRLF & _
"Marissa Gilbert C"
Local $sSubst = "$0."
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)