$re = '/(?<=[\hA-Z])[A-Z]$|[A-Z](?=[\hA-Z])/m';
$str = 'Patrick TJ Stephens
TJ Stephens
TJ Stephens QC
Marissa C J Gilbert
Marissa C Gilbert
C Marissa Gilbert
Marissa Gilbert C';
$subst = "$0.";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;