import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[\\hA-Z])[A-Z]$|[A-Z](?=[\\hA-Z])";
final String string = "Patrick TJ Stephens\n"
+ "TJ Stephens\n"
+ "TJ Stephens QC\n"
+ "Marissa C J Gilbert\n"
+ "Marissa C Gilbert\n"
+ "C Marissa Gilbert\n"
+ "Marissa Gilbert C";
final String subst = "$0.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}