use strict;
my $str = 'Patrick TJ Stephens
TJ Stephens
TJ Stephens QC
Marissa C J Gilbert
Marissa C Gilbert
C Marissa Gilbert
Marissa Gilbert C';
my $regex = qr/(?<=[\hA-Z])[A-Z]$|[A-Z](?=[\hA-Z])/mp;
my $subst = '$0.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";