import Foundation
let pattern = #"(?<=[\hA-Z])[A-Z]$|[A-Z](?=[\hA-Z])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Patrick TJ Stephens
TJ Stephens
TJ Stephens QC
Marissa C J Gilbert
Marissa C Gilbert
C Marissa Gilbert
Marissa Gilbert C
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0."#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)