#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.*\W|^)bar(\W.*|$)"
Local $sString = "Foo | Boolean Result" & @CRLF & _
"" & @CRLF & _
"blah bar / boo doo | True" & @CRLF & _
"" & @CRLF & _
"but is / should not match | False" & @CRLF & _
"" & @CRLF & _
"but match / here bar | True"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")