$re = '/(.*\W|^)bar(\W.*|$)/';
$str = 'Foo | Boolean Result
blah bar / boo doo | True
but is / should not match | False
but match / here bar | True';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);