re = /(.*\W|^)bar(\W.*|$)/
str = 'Foo | Boolean Result
blah bar / boo doo | True
but is / should not match | False
but match / here bar | True'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end