using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*\W|^)bar(\W.*|$)";
string input = @"Foo | Boolean Result
blah bar / boo doo | True
but is / should not match | False
but match / here bar | True";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}