package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*\W|^)bar(\W.*|$)`)
var str = `Foo | Boolean Result
blah bar / boo doo | True
but is / should not match | False
but match / here bar | True`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}