package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\w\*]+(\s)*?){2,4}\(([^!@#$+%^;]*?)\)\s*{`)
var str = `int test()
{
int test(int a) {
int test(int a, int b){
int test(int a,int b) {
_int _test(string * b){
int test (string b)
{
int test (string b) {
int
b
(int a)
{
test:
int test();
static int main(){
_static _void _itnt * main(){
static timerr iftnst
([A-z_]+\ *){3}(\(.*\))
Copyright (C) Stefan Frings`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}