import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\w\\*]+(\\s)*?){2,4}\\(([^!@#$+%^;]*?)\\)\\s*\\{";
final String string = "int test()\n"
+ "{\n"
+ "int test(int a) {\n"
+ "int test(int a, int b){\n"
+ "int test(int a,int b) {\n"
+ "_int _test(string * b){\n"
+ "int test (string b)\n"
+ "{\n"
+ "int test (string b) {\n\n"
+ "int\n"
+ "b \n"
+ "(int a)\n"
+ "{\n\n\n"
+ "test:\n"
+ "int test();\n"
+ " static int main(){\n"
+ "_static _void _itnt * main(){\n\n"
+ "static timerr iftnst\n\n"
+ "([A-z_]+\\ *){3}(\\(.*\\))\n"
+ "Copyright (C) Stefan Frings";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}