import re
regex = re.compile(r"([\w\*]+(\s)*?){2,4}\(([^!@#$+%^;]*?)\)\s*{", flags=re.MULTILINE)
test_str = ("int test()\n"
"{\n"
"int test(int a) {\n"
"int test(int a, int b){\n"
"int test(int a,int b) {\n"
"_int _test(string * b){\n"
"int test (string b)\n"
"{\n"
"int test (string b) {\n\n"
"int\n"
"b \n"
"(int a)\n"
"{\n\n\n"
"test:\n"
"int test();\n"
" static int main(){\n"
"_static _void _itnt * main(){\n\n"
"static timerr iftnst\n\n"
"([A-z_]+\\ *){3}(\\(.*\\))\n"
"Copyright (C) Stefan Frings")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")