const regex = new RegExp('([\\w\\*]+(\\s)*?){2,4}\\(([^!@#$+%^;]*?)\\)\\s*{', 'gm')
const str = `int test()
{
int test(int a) {
int test(int a, int b){
int test(int a,int b) {
_int _test(string * b){
int test (string b)
{
int test (string b) {
int
b
(int a)
{
test:
int test();
static int main(){
_static _void _itnt * main(){
static timerr iftnst
([A-z_]+\\ *){3}(\\(.*\\))
Copyright (C) Stefan Frings`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}