$re = '/([\w\*]+(\s)*?){2,4}\(([^!@#$+%^;]*?)\)\s*{/m';
$str = 'int test()
{
int test(int a) {
int test(int a, int b){
int test(int a,int b) {
_int _test(string * b){
int test (string b)
{
int test (string b) {
int
b
(int a)
{
test:
int test();
static int main(){
_static _void _itnt * main(){
static timerr iftnst
([A-z_]+\\ *){3}(\\(.*\\))
Copyright (C) Stefan Frings';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);