const regex = /(ZAR|R|)[-\$\d,.]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(ZAR|R|)[-\\$\\d,.]+', 'gm')
const str = `R1236 or ZAR1,236.00 1236 witt \$1236, 1,236.00 or 1236.00
Total Amount Due -1234
Total -1234
Total Due -1234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}