import re
regex = re.compile(r"(ZAR|R|)[-\$\d,.]+", flags=re.MULTILINE)
test_str = ("R1236 or ZAR1,236.00 1236 witt $1236, 1,236.00 or 1236.00\n\n"
"Total Amount Due -1234\n"
"Total -1234\n"
"Total Due -1234")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")