# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s+\d+$//gm;t' <<< "0 100 Continuity_PPMU_mV XSCI 140
1 100 Continuity_PPMU_mV XSCI 12
2 100 Continuity_PPMU_mV XSCI 76
3 100 Continuity_PPMU_mV XSCI 204
4 101 Continuity_PPMU_mV XSCO 139"