#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s+\d+$"
Local $sString = "0 100 Continuity_PPMU_mV XSCI 140" & @CRLF & _
"1 100 Continuity_PPMU_mV XSCI 12" & @CRLF & _
"2 100 Continuity_PPMU_mV XSCI 76" & @CRLF & _
"3 100 Continuity_PPMU_mV XSCI 204" & @CRLF & _
"4 101 Continuity_PPMU_mV XSCO 139"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)