import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s+\\d+$";
final String string = "0 100 Continuity_PPMU_mV XSCI 140\n"
+ "1 100 Continuity_PPMU_mV XSCI 12\n"
+ "2 100 Continuity_PPMU_mV XSCI 76\n"
+ "3 100 Continuity_PPMU_mV XSCI 204\n"
+ "4 101 Continuity_PPMU_mV XSCO 139";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}