import Foundation
let pattern = #"\s+\d+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0 100 Continuity_PPMU_mV XSCI 140
1 100 Continuity_PPMU_mV XSCI 12
2 100 Continuity_PPMU_mV XSCI 76
3 100 Continuity_PPMU_mV XSCI 204
4 101 Continuity_PPMU_mV XSCO 139
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)