$re = '/\s+\d+$/m';
$str = '0 100 Continuity_PPMU_mV XSCI 140
1 100 Continuity_PPMU_mV XSCI 12
2 100 Continuity_PPMU_mV XSCI 76
3 100 Continuity_PPMU_mV XSCI 204
4 101 Continuity_PPMU_mV XSCO 139';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;