# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\d+),([^,]+),(\d+)$/INSERT INTO cbl_student_competencies SET StudentID = $1, CompetencyID = (SELECT ID FROM cbl_competencies WHERE Code = "$2"), Level = $3, EnteredVia = "enrollment" ON DUPLICATE KEY UPDATE Level = Level;/gm;t' <<< "550,SS.2,10"