use strict;
my $str = '550,SS.2,10';
my $regex = qr/^(\d+),([^,]+),(\d+)$/mp;
my $subst = 'INSERT INTO cbl_student_competencies SET StudentID = $1, CompetencyID = (SELECT ID FROM cbl_competencies WHERE Code = "$2"), Level = $3, EnteredVia = "enrollment" ON DUPLICATE KEY UPDATE Level = Level;';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";