#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\d+),([^,]+),(\d+)$"
Local $sString = "550,SS.2,10"
Local $sSubst = "INSERT INTO cbl_student_competencies SET StudentID = $1, CompetencyID = (SELECT ID FROM cbl_competencies WHERE Code = "$2"), Level = $3, EnteredVia = "enrollment" ON DUPLICATE KEY UPDATE Level = Level;"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)