$re = '/^(\d+),([^,]+),(\d+)$/m';
$str = '550,SS.2,10';
$subst = "INSERT INTO cbl_student_competencies SET StudentID = $1, CompetencyID = (SELECT ID FROM cbl_competencies WHERE Code = \"$2\"), Level = $3, EnteredVia = \"enrollment\" ON DUPLICATE KEY UPDATE Level = Level;";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;