// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d+),([^,]+),(\d+)$").unwrap();
let string = "550,SS.2,10";
let substitution = "INSERT INTO cbl_student_competencies SET StudentID = $1, CompetencyID = (SELECT ID FROM cbl_competencies WHERE Code = \"$2\"), Level = $3, EnteredVia = \"enrollment\" ON DUPLICATE KEY UPDATE Level = Level;";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}