import Foundation
let pattern = #"^(\d+),([^,]+),(\d+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"550,SS.2,10"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"INSERT INTO cbl_student_competencies SET StudentID = $1, CompetencyID = (SELECT ID FROM cbl_competencies WHERE Code = "$2"), Level = $3, EnteredVia = "enrollment" ON DUPLICATE KEY UPDATE Level = Level;"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)